Unable to access eBook in LaunchPad
Incident Report for LaunchPad
Postmortem

Our eBook partner, VitalSource has restored service and given the all clear from their side.

Posted Jul 26, 2022 - 15:40 EDT

Resolved
We are currently investigating an issue where students are receiving a "Sign In Error" message when trying to access an eBook within their course. This is being observed by LaunchPad users. Our technical team is aware and they are working to resolve this issue. We will update as soon as more information is available. We do apologize for the inconvenience.
Posted Jul 22, 2022 - 23:00 EDT