Intermittent Performance Degradation
Incident Report for LaunchPad
Resolved
All systems are back online and normal performance levels have been restored.
Posted May 31, 2022 - 13:20 EDT
Monitoring
Our team has implemented a fix to restore normal performance levels. We are continuing to monitor system performance to ensure LaunchPad continues to function as designed.
Posted May 31, 2022 - 11:00 EDT
Investigating
We are currently investigating potential errors being reported by students and instructors attempting to make changes in LaunchPad. Our team is currently working to restore normal performance levels. We apologize for any inconvenience.
Posted May 31, 2022 - 10:50 EDT
This incident affected: Student Application (Assessments, LearningCurve) and Instructor Application (LearningCurve, Instructor Course Page/Dashboard).