Macmillan Student Store order fulfillment delay
Incident Report for LaunchPad
Resolved
We are no longer experiencing a delay in processing orders on Student Store. All orders are being fulfilled within normal processing time
Posted Jan 17, 2023 - 15:53 EST
Monitoring
We are no longer experiencing a delay in processing orders on Student Store. All orders are being fulfilled within normal processing time. We will continue to monitor this issue to ensure normal order fulfillment continues.
Posted Jan 13, 2023 - 14:36 EST
Update
We are continuing to investigate a delay in processing orders on Student Store. All orders are being processed within 30 minutes, with most orders being fulfilled in 15-20 minutes. If you recently placed an order and have not received a confirmation email, please do not place a new order. Thank you for your patience while we continue to troubleshoot the issue.
Posted Jan 12, 2023 - 17:30 EST
Investigating
We are currently experiencing a delay in processing orders on Student Store. All orders are being processed within 15 minutes. If you recently placed an order and have not received a confirmation email, please do not place a new order. Thank you for your patience while we continue to troubleshoot the issue.
Posted Jan 12, 2023 - 11:13 EST
This incident affected: Student Application (Assessments, LearningCurve, VideoTool/Go React, ACES, Writer's Help, eBook, Campus LMS integration).