500 - Internal Server error
Incident Report for LaunchPad
Resolved
Our team found and updated an isolated problem in the infrastructure which was leading to the intermittent 500 - Internal Server error.

LaunchPad is now performing as expected and we are no longer seeing the 500 - Internal Server error. We will continue to monitor closely.
Posted Feb 23, 2024 - 12:49 EST
Investigating
We are investigating instances of a "500 - Internal Server error" message appearing intermittently on Launchpad which prevents content from loading. In the interim please refresh your browser and which should resolve the issue in the short term. We are investigating this issue further and will post an update when it has been resolved.
Posted Feb 23, 2024 - 11:40 EST